Перейти к содержимому


Установка локальной версии: зависает с ошибкой


Сообщений в теме: 6

#1 arsenal

    Активный участник

  • Пользователи
  • PipPipPip
  • 448 сообщений

Отправлено 12 Октябрь 2019 - 12:21

Добрый день.
Скачал дистрибутив LOCAL 3.0.1.
Пытаюсь установить. Но на этапе скачивания локального сервера зависает и не скачивает его. Потом выдает ошибку

Прикрепленные изображения

  • Прикрепленное изображение: Без имени.png


#2 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 706 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 14 Октябрь 2019 - 10:08

Скорее всего прокси блокирует. Можно скачать локальный сервер вручную по ссылке https://clientbase.r...lserver_3.0.exe и затем переместить его в корень диска на который ставите программу. В этом случае инсталятор возьмет его оттуда.

#3 arsenal

    Активный участник

  • Пользователи
  • PipPipPip
  • 448 сообщений

Отправлено 25 Октябрь 2019 - 16:49

Всё установил, спасибо.
При попытке загрузить бэкап (из версии 2.0.11) выводит ошибку
Warning: POST Content-Length of 32120981 bytes exceeds the limit of 8388608 bytes in Unknown on line 0

#4 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 706 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 28 Октябрь 2019 - 10:07

Видимо размер бэкапа очень большой для загрузки через браузер. Попробуйте скопировать файл напрямую в папку C:\Program Files (x86)\MSTL\ClientBase\www\backup и затем выберите его из внутреннего архива.

#5 arsenal

    Активный участник

  • Пользователи
  • PipPipPip
  • 448 сообщений

Отправлено 29 Октябрь 2019 - 20:21

Именно так и делал, из внутреннего архива, не получается. Да и размер небольшой, 30Мб.
Причем изначально архив был из версии 2.0.9. Пробовал сразу загрузить в 3.0.1, появляется вышеуказанная ошибка.
Установил версию 2.0.11, в нее нормально загружается.

#6 arsenal

    Активный участник

  • Пользователи
  • PipPipPip
  • 448 сообщений

Отправлено 30 Октябрь 2019 - 15:52

Путем нескольких удалений и повторных установок программы 3.0.1 вроде бэкап загрузился. Не понятно в чем была проблема.
Все категории, таблицы и представления нормально открываются и отображаются.
Но при попытке в настройках зайти в представление (любое) для его редактирования вылетает ошибка:
Fatal error: Uncaught PDOException: could not find driver in C:\Program Files\MSTL\ClientBase\www\classes\report\Apiloc.php:89 Stack trace: #0 C:\Program Files\MSTL\ClientBase\www\classes\report\Apiloc.php(89): PDO->__construct('mysql:host=loca...', 'root', 'otjcXsadfI') #1 C:\Program Files\MSTL\ClientBase\www\classes\report\Apiloc.php(39): ClientBase\Report\Apiloc->__construct(Array, Array) #2 C:\Program Files\MSTL\ClientBase\www\edit_report.php(323): ClientBase\Report\Apiloc::getInstance(Array, Array) #3 {main} thrown in C:\Program Files\MSTL\ClientBase\www\classes\report\Apiloc.php on line 89
Это именно только в представлениях.

#7 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 706 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 30 Октябрь 2019 - 16:24

Это баг локального сервера, один из модулей не прописан, который нужен для нового функционала. Отправьте заявку в техподдержку.





Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных