Перейти к содержимому


Ошибка при установке / первом запуске


Сообщений в теме: 52

#21 exise

    Участник

  • Пользователи
  • PipPip
  • 15 сообщений
  • Пол:Мужчина
  • Город:Екатеринбург

Отправлено 24 Март 2010 - 18:17

Хостеру своему CRM отправил, что-там проверять будут.
Я на свой комп (OpenSUSE 11.2) поставил: XAMPP 1.7.1 + eAccelerator + ZendOptimizer 3.3.3 - и все отлично работает!
(кстати XAMPP 1.7.3 - не ставьте, там PHP 5.3.x - гемороя хапните на несколько дней или недель, весь инет перероете!)

Вывод:
Нафиг этот хостер геморойный. Я и на своей машине могу и во внешку дать доступ и ограничить и закрыть.

Вот так я проблему решил =)
Продам CRM "Клиентская База" в Екатеринбурге - очень дорого, но красиво. ;-)

#22 exise

    Участник

  • Пользователи
  • PipPip
  • 15 сообщений
  • Пол:Мужчина
  • Город:Екатеринбург

Отправлено 25 Март 2010 - 21:19

Что-то хостер мой подпрвил у себя на сервере, сейчас CRM работает и на хостинге
Продам CRM "Клиентская База" в Екатеринбурге - очень дорого, но красиво. ;-)

#23 Rezo

    Активный участник

  • Пользователи
  • PipPipPip
  • 122 сообщений

Отправлено 09 Апрель 2010 - 16:06

E меня такая проблема:

Установил новую версию на сервер, пытаюсь загрузить сделанный ранее backup система выдает сообщение:

Fatal error: Table 'csbcrm_cb.f_config' doesn't exist

SELECT * FROM f_config

in /home/csbcrm/public_html/backup.php on line 158



а после этого при попытке зайти в базу


Fatal error: Table 'csbcrm_cb.f_config' doesn't exist

SELECT * FROM f_config

in /home/csbcrm/public_html/common.php on line 30

Больше в базу зайти не получается, как с этим бороться????

#24 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 09 Апрель 2010 - 16:16

Префикс у таблиц не меняли при установке? Скорее всего сбой по этой причине, хотя может и нет, сейчас трудно установить. Переустановите программу и попробуйте заново залить бэкап. Если не получится - загрузите напрямую в базу, например через phpMyAdmin

#25 Rezo

    Активный участник

  • Пользователи
  • PipPipPip
  • 122 сообщений

Отправлено 09 Апрель 2010 - 18:03

Просмотр сообщенияРазработчик (9.4.2010, 16:16) писал:

Префикс у таблиц не меняли при установке? Скорее всего сбой по этой причине, хотя может и нет, сейчас трудно установить. Переустановите программу и попробуйте заново залить бэкап. Если не получится - загрузите напрямую в базу, например через phpMyAdmin


Префикс не менял, переустанавливал все тоже.

Залил backup через phpMyAdmin, база запускается, но при попытке создать backup во внешний файл и загрузить его выдает "Не выбран файл."

#26 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 09 Апрель 2010 - 18:08

Размер бэкапа скорее всего превышает максимально допустимый размер файла при загрузке через html форму. У вас же web версия как я понимаю?

#27 Rezo

    Активный участник

  • Пользователи
  • PipPipPip
  • 122 сообщений

Отправлено 09 Апрель 2010 - 18:24

Просмотр сообщенияРазработчик (9.4.2010, 18:08) писал:

Размер бэкапа скорее всего превышает максимально допустимый размер файла при загрузке через html форму. У вас же web версия как я понимаю?

Да web, а какой максимальный размер может быть? У меня 3,7 мб

#28 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 09 Апрель 2010 - 18:31

По умолчанию в php стоит 2Мб. Как увеличить - это вам надо узнать у вашего хостера. Вообще чем больше тем лучше.

#29 Rezo

    Активный участник

  • Пользователи
  • PipPipPip
  • 122 сообщений

Отправлено 09 Апрель 2010 - 18:50

Просмотр сообщенияРазработчик (9.4.2010, 18:31) писал:

По умолчанию в php стоит 2Мб. Как увеличить - это вам надо узнать у вашего хостера. Вообще чем больше тем лучше.


Но ведь раньше загружалось все?

Еще вчера, дло того как решил поменять базу на новую версию?

#30 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 09 Апрель 2010 - 18:55

Размер бэкапа в новой версии мог вырасти. Изменен формат хранения загруженных файлов из-за проблем с совместимостью.

#31 ajmal

    Новичок

  • Пользователи
  • Pip
  • 7 сообщений

Отправлено 15 Июнь 2010 - 14:40

Добрый день...
Попытался установить вэб версию... сталкнулся с проблемой.. выдает ошибку "404 ничего не найдено"... путь однозначно правильный...
К примеру путь выглядит так: www.mydoamin.com/cb/index.php, но выдает ошибку. Не совсем понимаю в чем проблема... в readme написано всего 3 предложения, распакуйт и запустите... даже не написано что именно запускать .../index.php или .../setup.php

Подскажите плиз где есть полноценная инструкция, чтобы я прошел пошагово весь путь или объясните как при точно введении пути.. он ничего не находит.

Заранее спасибо

#32 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 15 Июнь 2010 - 14:54

В инструкции написано "скопируйте на ваш сервер папку cb и запустите ее в браузере", т.е. в браузере необходимо набирать адрес папки, в вашем случае "http://www.mydoamin.com/cb/". Индексный файл при этом запустится автоматически. Если по указанному пути программа не запускается, значит проблема в вашем сервере (возможно неправильно набираете адрес, или есть какие то особенности запуска на данном хостинге, например как в теме "проблема установки на Masterhost")

#33 ajmal

    Новичок

  • Пользователи
  • Pip
  • 7 сообщений

Отправлено 16 Июнь 2010 - 21:48

Просмотр сообщенияРазработчик (15.6.2010, 14:54) писал:

В инструкции написано "скопируйте на ваш сервер папку cb и запустите ее в браузере", т.е. в браузере необходимо набирать адрес папки, в вашем случае "http://www.mydoamin.com/cb/".[/url])

Все проверил, проблема осталась. С сервером все нормально, все скрипты и остальные движки других разработчиков устанавливаются по первому клику.

#34 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 17 Июнь 2010 - 08:28

Уберите файл .htaccess из корня. Возможно у вас запрет на их использование.

#35 ajmal

    Новичок

  • Пользователи
  • Pip
  • 7 сообщений

Отправлено 17 Июнь 2010 - 08:52

Удалил .htaccess, все заработало, но пришлось принудительно прописывать www.mydomain.com/cb/index.php

Вот, что выдает сервер в логе ошибок.
[Thu Jun 17 00:47:20 2010] [alert] ..../public_html/cb/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration

#36 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 17 Июнь 2010 - 08:59

Значит сервер у вас по какой-то причине не принимает подобную команду. Попробуйте прописать .htaccess без этой строки.

#37 ajmal

    Новичок

  • Пользователи
  • Pip
  • 7 сообщений

Отправлено 17 Июнь 2010 - 09:11

Удалил строку... Скрипт запускается, но в принудительном порядке, если полностью прописать www.mydomain.com/cb/index.php
Буду решать вопрос с хостпровайдером.

#38 ajmal

    Новичок

  • Пользователи
  • Pip
  • 7 сообщений

Отправлено 19 Июнь 2010 - 23:35

Вот что написал мой хостпровайдер:

The reason for the previous error was that the .htaccess had a php_value in it, this is not supported on our servers, and any custom php configurations have to be made with a php.ini, you can make these modifications through cpanels easy php.ini or quick config php.ini depending on your theme. It would appear that php is unable to read the index file, likely due to the encoding conflict.

#39 Kumigy

    Активный участник

  • Пользователи
  • PipPipPip
  • 36 сообщений
  • Пол:Мужчина
  • Город:Екатеринбург

Отправлено 23 Ноябрь 2010 - 16:17

Подскажите пожалуйста по проблеме.
Сервер:
Windows 2008 + IIS + PHP +MySQL

Пытаюсь запустить Клиентскую БАзу получаю ошибку:
PHP Warning: main(/lang/russian.php) [function.main]: failed to open stream: No such file or directory in D:\www\cb\common.php on line 50 PHP Fatal error: main() [function.require]: Failed opening required '/lang/russian.php' (include_path='.;D:\www\') in D:\www\cb\common.php on line 50

Не знаю, что это значит :blink: Подскажите пожалуйста, куда копать и чего править?

#40 CbCoder

    Активный участник

  • Программист ООО "КБ"
  • PipPipPip
  • 8 722 сообщений
  • Пол:Мужчина
  • Город:Казань

Отправлено 23 Ноябрь 2010 - 16:40

Ну в общем все достаточно очевидно уже из текста ошибки - "невозможно открыть файл /lang/russian.php". Проверьте наличие этого файла и права на его чтение.





Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных